SafetyNet Google Play Warning

Applications integrating Malwarelytics for Android receive a warning in the Google Play console regarding the deprecation of the SafetyNet Attestation API and its replacement with Play Integrity API. This warning is a false positive, the developers can safely ignore it because Malwarelytics for Android does not use SafetyNet Attestation API, it only uses a common dependency.

Details

Malwarelytics for Android integrates SafetyNet Verify Apps API which is one of several APIs provided by one common SafetyNet dependency (com.google.android.gms:play-services-safetynet). Google Play automated checks seem to detect the presence of the dependency (or some of its classes) and warn the developer about the deprecation of the SafetyNet Attestation API and its replacement with Play Integrity API.

The SafetyNet Verify Apps API is distinct from both the SafetyNet Attestation API and its replacement, the Play Integrity API. The Verify Apps API is not deprecated.

More information about SafetyNet Verify Apps API can be found in the documentation.

Last updated on Nov 27, 2023 (14:00) View product
Search

develop

Malwarelytics for Android